First time here? Check out the FAQ!
x

My Flip Video camera will not launch.

0 votes
asked by about FlipShare
edited by

When I press the power button a message in the screen reads 'Hold (the red circled button) for set up'. This stays on the screen for about 5 seconds then goes. I have tried two sets of brand new batteries but there is no difference. I have also plugged the camera into a USB port with the same result except that the message keeps on being repeated at short intervals. Any suggestions as to the problem and a solution?

1 Answer

0 votes
answered by (329k points)
edited by

I would recommend to perform a full reinstallation regarding the drivers and the software. You can use Revo Uninstaller. Even if it can't uninstall the application normally, it will force it to uninstall by wiping out all traces of its presence from the system.

Once you finish with the uninstall part, reboot the PC and then use the setup package and reinstall the drivers. I would check the Device Manager as well. Press Windows +R and type devmgmt.msc. Make sure that the device is not connected to PC.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...