First time here? Check out the FAQ!
x

Information about Microsoft Flight Simulator 3.1

0 votes
asked by about Microsoft Combat Flight Simulator
edited by

Since installing Windows 10, I can't play Microsoft Flight Simulator 3.1. I have tried to go back to 8.1 but can't. It says "The game is not compatible". How do I make it so?

1 Answer

0 votes
answered by (264k points)
edited by

The Microsoft Flight Simulator 3.1 version is very old therefore modern systems might have issues running it. I recommend downloading the patch through the websites listed on Google. It's said it enhances functionality and compatibility. Additionally, apply a compatibility tweak to the game. Right click the main executable and go to Properties > Compatibility. Choose a prior version of Windows and then try launching the game this way.

I recommend getting the FSX version of Microsoft Flight Simulator. It's an updated version to support modern operating systems with enhanced graphics and features.

Steam: http://store.steampowered.com/app/314160

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...