First time here? Check out the FAQ!
x

How to fix error "Automation object not found"?

0 votes
asked by about Revo Uninstaller
edited by

How to fix error "Automation object not found"?

7 Answers

0 votes
answered by (236k points)

This is a major issues encountered by users. The fix was to Refresh/reinstall your operating system because there is no cause to this error. In many cases, I have see that the PCs were infected with malware and the OS had a lot of things changes regarding registry, DLL files, directory structure, etc. Reinstalling the application won't fix anything since other parts of the Windows operating system are messed up. You will either need to do a recovery or reinstall the operating system again.

Use the following guide to recover Windows OS: http://windows.microsoft.com/en-us/windows/what-are-system-recovery-options#what-are-system-recovery-options=windows-7

0 votes
answered by

Run as administrator the file root folder of the program "reg_lp.bat".

commented by (100 points)
Hi. That was. Thank you!
commented by (100 points)
This worked for me too!  After many failed attempts trying lots of other supposed fixes it is finally fixed!

Thank You Simon!
0 votes
answered by

Hi, I had the same error message. In my case there was a missing IDispatch interface registry key defined as a GUID with the value of {00020400-0000-0000-C000-000000000046}.

I suggest to use indispensable tools for investigation and hopefully fix the problem without reinstalling entire OS. These tools are called FileMon (file system activity) and RegMon (registry activity) by Mark Russinovich (there is also a hybrid tool called Process Monitor but is more "bloated" and OS demaning and as an example for Windows XP it requires SP2 - so I prefer the lighter separate tools.)

Before running one or the other you need to configure them to make all the missing entries highlighted during filesystem/registry monitoring activity. To do this press CTRL+L keys in each and in the "Highlight" box put "NOT FOUND" and click "OK". You will see all the missing registry entries highlighted in red and also missing file entries highlighted in red too.

But you can skip investigating the problem and try to fix it by reinstating the registry key below:

------------ Copy everything in between

[Version]
Signature = "$Windows NT$"
ClassGUID={00000000-0000-0000-0000-000000000000}
DriverVer=07/01/2001,5.1.2600.0

[DefaultInstall]
AddReg = IDispatch.Install.Reg

[IDispatch.Install.Reg]
HKCR,"Interface{00020400-0000-0000-C000-000000000046}","",0x00000002,"IDispatch"
HKCR,"Interface{00020400-0000-0000-C000-000000000046}\NumMethods","",0x00000002,"7"
HKCR,"Interface{00020400-0000-0000-C000-000000000046}\ProxyStubClsid","",0x00000002,"{00020420-0000-0000-C000-000000000046}"
HKCR,"Interface{00020400-0000-0000-C000-000000000046}\ProxyStubClsid32","",0x00000002,"{00020420-0000-0000-C000-000000000046}"

------------ Copy everything in between

and paste copied lines into a newly created file in notepad and save it as "IDispatch.addreg.inf" in your Windows "INF" folder (be sure that option "Show hidden files and folders" in Folder Options is ticked).

After that, right click on that file and choose "Install" from explorer context menu or invoke from command prompt or Start Menu/Run the following:

rundll32.exe SETUPAPI.DLL,InstallHinfSection DefaultInstall 132 IDispatch.addreg.inf

Registry files created by Windows Registry Editor have a bit different structure than the above keys pulled from HIVECLS.INF file(this one and few others are used to create the registry hives(fundamental keys, subkeys & values) for the installation of OS) and so these keys will not be imported by Windows Registry Editor without applying modifications.

Because I want to preserve the original structure I usually create small inf files (like the above one) and install them with either of the two methods described. Hope that helps!

--
Regards,
Robert Martin Konopka

0 votes
answered by

All of these answers might work but one of the main reasons for this error is that the license manager program ruplp.exe is not running when revo uninstaller loads. This program needs to run as administrator. You can fix the problem by ensuring that the program will run as administrator for all users, create a shortcut for it, and put the shortcut in the common start menu folder (shell:common startup). Reboot. Can't say that this will work for everyone but after trying all of the above suggestions, contacting VS Revo Group and running their recommendations (all with no results) running the license manager as administrator worked. You can test this before doing any of the above fixes by running the ruplp.exe file as administrator from the revo uninstaller folder and then launching Revo Uninstaller. Check in task manager first that ruplp.exe is not already running as a process. If it is, kill it and then launch it as administrator. hope this solves your problem. It did mine after days of tracing process and registry calls.

commented by (100 points)
It Worked!
commented by (100 points)
it works too to me!
0 votes
answered by

Tried this 1 -

Run as administrator the file root folder of the program "reg_lp.bat"

and it worked immediately!

Sure glad I did NOT REINSTALL Windows, or any of the other complicated 'fixes' mentioned.

(Thank you, Occam)

0 votes
answered by

Reinstall the App (Run as Administrator) and after `restarting windows´ it will be fixed!
I had the same problem (Error), after I upgraded the App to version 4.0.5.
And so I solved it.

0 votes
answered by

Yes, Revo Pro worked yesterday and this morning I got the Automation Object error. Ran ruplp.exe as Admin. Revo opened without having to restart PC. Hope will last. Thanks everyone.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...