First time here? Check out the FAQ!
x

My Spore game won't run. When I run it, it goes to a black screen and does nothing. What do I do?

0 votes
asked by about SPORE
edited by

My Spore game won't run. When I run it, it goes to a black screen and does nothing. What do I do?

2 Answers

0 votes
answered by (100k points)
edited by

The problem is with the location where the game has been installed (due to an error of the installer which does not unpack the whole data) and the version of Windows you are running. The fix to this problem might seem strange, but in order to get your copy of Spore to run correctly you need to manually copy the Data and Sporebin folders and paste them to the installation directory then start the game again and you will notice that the black screen problem will cease to appear. There is also another way of fixing the bug: to set your graphics to "low" and then try an run the game again.

0 votes
answered by

Just wanted to add the solution the worked for me.

Like most other people with this problem, I combed the forums across the internet and tried all the different ideas to try to fix the problem, but nothing worked. I tried adding-safe and -w to the shortcut target. I tried running it as admin. I tried reinstalling. I tried changing the config to make all the settings LOW quality, but I still got the black screen of death.

So I turned on the task manager while it was loading to see what it was doing... and I noticed that it was indeed loading, but every time it hit 135megs, it would stop. From there it would load only in painfully small increments of 8 or 12 bits a second. Even when I changed the priority and affinity to high. So I figured there was nothing left to do except let it load.

Long story short, I let it load for over 4 hours - to no avail... It was over 300megs and still ticking up when I stopped it. But it dawned on me what might be the problem. I'd been playing Spore for years and had maybe around 20 different civilizations. Maybe it was just too much to load...

So this time when I reinstalled, I (reluctantly) deleted all my game data... AND... It worked! Spore loaded in seconds. Kinda sucks to lose years of creation, but also kinda fun to start fresh again.

So it turns out my problem was that my game data files were too big to load - Spore couldn't handle it. If you've tried everything and nothing helps, maybe you just need a fresh start too.

carpefunk
Win 7 - 64 bit

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...