First time here? Check out the FAQ!
x

New Yahoo Mail app is not compatible anymore with my phone.

0 votes
asked by
edited by

I've a HTC Desire HD with Android 2.3.5 and I need the link to the previous Yahoo Mail update prior to Feb 2015 because it's not compatible with my device.

1 Answer

0 votes
answered by (264k points)

The application's page at Google Play Store doesn't offer the possibility to download an older version of the software. You have two possibilities:

  1. Go to Settings > Applications > All > Yahoo Mail. Tap on it and then tap on Uninstall Updates.

  2. Use the available email address to get in touch with the developer. Ask him about an older version of the software: ymailandroid@yahoo.com

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...