First time here? Check out the FAQ!
x

Bluestacks automatically downloads applications. How to stop this process?

+1 vote
asked Apr 11, 2014 about AppCast for BlueStacks
edited Apr 11, 2014 by William Rasmussen

Bluestacks automatically downloads applications. How to stop this process?

11 Answers

+1 vote
answered Apr 11, 2014 by Sean Hill (305,930 points)

To stop the automatic downloading, open Bluestacks then locate Play Store. Press the settings menu and disable Auto update apps. Set this option to Never and Bluestacks will stop downloading applications automatically. In fact this process is actually called updating. It updates installed applications when there is an update.

0 votes
answered May 31, 2014

that's just for auto update.

bluestacks has diff kind problem. it downloads new apps what we can't want. when I delete that apps , it download thm again... how can i stop it.

0 votes
answered Jun 2, 2014

dear,
no word in apps store like "never" it's continue and continues auto download

0 votes
answered Jun 9, 2014

having the same issue as this one, i think i know what he/she means. the problem is not with updates/ auto updates. the problem is, bluestack keep downloading those app that i never want automatically and install them without my permission and knowledge, thus using my quota. whenever i check for app installed, there will be 3 or 4 apps which i never encountered before installed in it :( hates it.. i will just stop using bluestack until this is stopped

0 votes
answered Jul 26, 2014
edited Jul 26, 2014

I found the solution
just change your Google/Gmail password so you will automatically logged out of Google play store. next time when you open Bluestack one pop up ask you to "enable app sync" never do that because that was the culprit application.

0 votes
answered Sep 4, 2014

Step 1: Open BlueStacks while your PC/Laptop is not connected to the internet.
Step 2: Go to Settings/Apps
Step 3: Select Running Apps
Step 4: Stop all unwanted services such as Game-pop Home, AppCaster, Google services, especially Google Store, or any other such unwanted service.

Voila.! Now you can start your internet connection.

P.S. :- You have to repeat these steps every time you start BlueStacks. It'll take just a minute or so. And still if you get a notification of any unwanted game or application that starts downloading, you can follow the following steps:-

  1. Go to Settings/Apps/All.
  2. Search for the culprit (such as AppCaster, GamePop,etc)
  3. Select "Force Stop".

Done Deal.

0 votes
answered Sep 26, 2014

Go to apps setting and disable play store

0 votes
answered Oct 25, 2014 by Jebin

GET SIGNED OUT FROM GOOGLE.... THE PROBLEM GETS SOLVED ...:)

0 votes
answered Dec 10, 2014 by Tim

Install "App Master" from the Play Store. It has an advanced Auto-Start Boot manager. Just disable everything related to GamePop. Problem solved.

0 votes
answered Dec 19, 2014

Step 1: Open BlueStacks while your PC/Laptop is not connected to the internet.
Step 2: Go to Settings/Apps
Step 3: Select Running Apps
Step 4: Stop all unwanted services such as Game-pop Home, AppCaster, Google services, especially Google Store, or any other such unwanted service.

Voila.! Now you can start your internet connection.

P.S. :- You have to repeat these steps every time you start BlueStacks. It'll take just a minute or so. And still if you get a notification of any unwanted game or application that starts downloading, you can follow the following steps:-
1.Go to Settings/Apps/All.
2.Search for the culprit (such as AppCaster, GamePop,etc)
3.Select "Force Stop".

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...