First time here? Check out the FAQ!
x

Can you tell me, what kind of Java is required for World of Tanks?

0 votes
asked by
edited by

Can you tell me, what kind of Java is required for World of Tanks?

1 Answer

0 votes
answered by (264k points)

World of Tanks does not requires a specific version of Java. Simply install the latest version available from its official website and it should be enough for the game to run properly. Additionally, try to install Adobe Flash Player.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...