First time here? Check out the FAQ!
x

Do I need an update for Netscape 6.0 to use it on Windows XP?

0 votes
asked by
edited by

Do I need an update for Netscape 6.0 to use it on Windows XP?

1 Answer

0 votes
answered by (80k points)

No, you don't need to update the software. The Netscape Communicator version 6.0 is compatible with Windows XP.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...