First time here? Check out the FAQ!
x

I downloaded the latest version and I received a message that my operating system is not correct for this version. Can you help?

0 votes
asked by about Dell Support Center
edited by

I downloaded the latest version and I received a message that my operating system is not correct for this version. Can you help?

1 Answer

0 votes
answered by (132k points)

I suggest you to download and install the latest version from the official web page. It is compatible with Windows XP, Windows Vista, Windows 7 and Windows 8 on both 32 and 64-bit architecture. If you still have issues, contact a Dell expert.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...