First time here? Check out the FAQ!
x

Ulead iPhotoExpress cannot be installed properly.

0 votes
asked by
edited by

I cannot use my old disc with iPhotoExpress (an image editor) on my new computer. When I insert it, my computer tells me "Version of file is not compatible with versions of Windows you are running. Check your computer to see if you need an X86 (32bit) or X64 (64bit) version of the program"

What can I do to retrieve that great image editor without which I cannot do anything?

1 Answer

0 votes
answered by (100k points)
edited by

The application is OLD and is not compatible with the the latest operating systems. Ulead has been acquired by Corel Company and its previous products were discontinued or replaced with new ones. In this case, I suggest you use Paintshop Pro, an advanced photo editor designed by the same company. If you were familiar with the Ulead interlace, you will soon notice that the same interface was preserved to please users along the way.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...