First time here? Check out the FAQ!
x

Do you have an upgrade for Netvu Observer that works with Apple 11.0?

0 votes
asked by
edited by

Do you have an upgrade for Netvu Observer that works with Apple 11.0?

1 Answer

0 votes
answered by (329k points)

On the App Store, Netvu Observer is listed to be compatible with the following versions and devices: requires iOS 5.0 or later. Compatible with iPhone, iPad, and iPod touch.

This means you will have the possibility to install it on the devices running iOS 5.0 or later. You can get the program from the official website.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...