First time here? Check out the FAQ!
x

Updating LP Recorder and LP Ripper

0 votes
asked May 28 by Billy about LP Ripper
edited Jun 23 by Stephen Prastman

I own the 2.8 version of the Pro edition, but when I try to update to version 8.0, I am prompted to install the limited capabilities trial version. Do I need to pay again in order to use the pro version in this update? The 2.8 version of the tool still works perfectly well when used in compatibility mode.

1 Answer

0 votes
answered Jun 23 by Stephen Prastman (254,570 points)

The best advice that I can give you is to contact the company that makes LP Ripper directly using this email address info@cfbsoftware.com and ask them about your situation.

I'm not familiar with the company's policy on updates, but you may need to buy the software again especially since you own the 2.8 version of it and the most recent version of LP Ripper is 11.0. However, if the old version is still working for you and you don't need the features that have been added since, you can simply keep using the one you have.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...