First time here? Check out the FAQ!
x

Driver issues with CoolingTech Microscope

0 votes
asked by about CoolingTech Microscope
edited by

I've just installed the driver for the microscope and all I get is a window that says "Please connect device". The problem is that it is connected. I even unconnected it and reconnected it again, but nothing changes.

3 Answers

0 votes
answered by (264k points)
edited by

It's very likely that the driver hasn't been installed properly or that you don't have the right one for your version of Windows. Try uninstalling the driver, restarting your PC, then reinstalling it (making sure that it's the right one for your Windows) and rebooting again.

Additionally, you can try uninstalling and reinstalling the application as some freak accident may have caused it to not install or register properly.

Lastly, try using a different USB port, preferably one that you've tested with a different device and that you know for sure is working.

0 votes
answered by

/how do i download the driver ans soft ware when i do not have a cd drive on my laptop

0 votes
answered by (140 points)

The microscope does not work in any way, it took many hours lost installing it in one way or another. It's a scam buying that microscope. You have to proceed to report it

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...