First time here? Check out the FAQ!

After Windows reinstallation Instant-On doesn't work anymore.

0 votes
asked by about ASUS InstantOn
edited by


I bought my ASUS PC with Instant-On already installed, and it worked correctly also after I updated my PC from Windows 8.1 to Windows 10.

Now, I had to re-install Windows 10 due to some virus problems, and Instant-On is not anymore available. I have also downloaded it from your site, but it seems I cannot install it because "In my PC there isn't the Instant On built-in" (these are approx the words of the error message that PC shows when trying to install Instant On).

Can you help me please? I really don't know how to proceed.

Thanks for your attention and best regards.
Stefano Conti

1 Answer

0 votes
answered by (309k points)

The ASUS InstantOn relies on the ATKACPI driver and on the ATK hotkey utility to work. If you don't have these installed, then it doesn't matter the InstantOn version, because you'll receive the same error message like the one below:

enter image description here

Make sure to visit the support page for your device and download the driver and the utility and then install InstantOn and it should work.

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register