First time here? Check out the FAQ!
x

Domino 7 is unable to start and shows: "PANIC: existing named shared memory region size is too small".

0 votes
asked by (120 points)
edited by

I have a problem about Lotus Domino 7.2. Our server suddenly shows up "PANIC: existing named shared memory region size is too small", after that all users are unable connect to the server. The server crashed once before and we just re-install it for the other side. I am making a replication from the other server for the corrupt database. We already try to restart the server, but it's still showing the same error and unable to start the Domino.
Finally we found some error log in "sysinfoW32Iserver20130715@2125_53.log" and talking about.

Generated Messages:
   INFO (0): failed to match all of the Notes processes
   WARNING (3): can't get process 2952 status
   ERROR (0): no active processes found for this instance
   ERROR (4): can't attach to process [   nsmtp:  0b88] - (87) The parameter is incorrect.

Do you have any idea to fix that problem?

2 Answers

0 votes
answered by (140 points)
reshown by

Apparently there are several corrupt databases. Your Domino server must have crashed once, before it started to show the out-of-memory errors.
What needs to be done:
- shut down Domino
- make a back-up of the whole Domino environment
- make sure that the Domino executables folder is in your path
- open a Command Prompt window
- change directory to the Domino data directory
- run FIXUP on all databases, this is a tool to repair databases, it throws away corrupt documents (they will be restored from a replica on another server when available)
- example: nfixup names.nsf =E:\Lotus\directory\notes.ini. Or you can use Lotus Notes Repair Kit http://www.lotusnotes.repair/
- when done, restart your Domino server
Better shut down the Domino server before running the fixup tool or Lotus Notes Repair Kit . It doesn't have anything to do with allocated memory directly, but it removes corrupt documents. These corrupt documents can make the server crash.

The fixup tool is in the same directory as the notes.exe file, it's called fixup.exe or nfixup.exe

0 votes
answered by (329k points)

This is a problem related to database corruption. You need create a backup of the Domino environment and then run the FIXUP command. You can find the FIXUP application in the same directory as the notes.exe file.

This error has been discussed on the IBM forums and it has been marked as being solved. The FIXUP command is known to fix issues when the database is failing.

Proper usage: nfixup or FIXUP names.nsf =E:\Lotus\directory\notes.in

Your answer

Your name to display (optional):
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...