First time here? Check out the FAQ!
x
 Windows  Mac  Android  Answers  Forum

What version of AutoSketch is required to work with Windows 10?

0 votes

What version of AutoSketch is required to work with Windows 10?

asked Aug 31 by Kerswill
edited Sep 1 by Alex Urbach

1 Answer

0 votes

AutoSketch is actually a discontinued application. This means you won't have the possibility to obtain new versions of the software as well as licenses to use it since it was a commercial product. The old link that lead to the AutoDesk website is no longer working and there have been reports on the Autodesk forums that the product is nowhere to be found.

You will have to choose other applications from this category since AutoSketch is no longer available. At this point, your alternatives are: AutoCAD LT and Sketchbook Pro.

answered Sep 1 by Alex Urbach (304,940 points)

Your answer

Your name to display (optional):
Email me at this address if my answer is selected or commented on:
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...