First time here? Check out the FAQ!
x
 Windows  Mac  Android  Answers  Forum

EchocontactEchocontact ›  Is EchoContact 3.2 compatible with Windows 10?

0 votes

Is EchoContact 3.2 compatible with Windows 10?

asked Aug 8 by anonymous
edited Aug 9 by Alex Urbach

1 Answer

0 votes

No, the software doesn't work with the Windows 10 operating system, primarily because this is a very old application. According to a statement on the Genesys website, it appears that Echopass (the developers of EchoContact) have been acquired by Genesys. The EchoContact was somehow merged into the new applications. You will have to check the products of Genesys to see if there is one which corresponds to your needs.

However, if you still have that version, right click it and go to Properties > Compatibility. Choose a previous version of Windows from the list and then launch it. If it doesn't work, you'll have to use Genesys products.

answered Aug 9 by Alex Urbach (300,860 points)

Your answer

Your name to display (optional):
Email me at this address if my answer is selected or commented on:
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...