First time here? Check out the FAQ!
x
 Windows  Mac  Android  Answers  Forum

Android studio 2.3.1 not working on Kali Linux

0 votes

I installed Android Studio 2.3.1 on Linux 32bit machine (Kali Linux). It is successfully installed. When I tried to create an application, the following errors appeared:

When I start to run an application on the external device, it will generate the following error

Error message: Unable to detect adb version, adb output: /home/elsi/Android/Sdk/platform-tools/adb: 1: /home/elsi/Android/Sdk/platform-tools/adb: Syntax error: ")" unexpected

I tried the following solution on the terminal

elsi@kali-Rolling:~/Android/Sdk/platform-tools$ adb kill-server
elsi@kali-Rolling:~/Android/Sdk/platform-tools$ adb start-server
* daemon not running. starting it now on port 5037 *
* daemon started successfully *
elsi@kali-Rolling:~/Android/Sdk/platform-tools$ adb devices
List of devices attached
793532E2034CF208 device

These are the current versions of Android SDK and Gradle version installed:
compileSdk version 25, buildTools version 25.0.3.

Still, the problem is not fixed. When I created a virtual device (emulator) to run the program, it also generates an error saying HAXM requires a genuine Intel processor. I tried to search for some solutions on the Internet, but Kali Linux does not support this processor, therefore, I installed KVM, and other required packages are not supported as well.

Please, I need a serious solution for the above problems.

asked Apr 26 by Dejene Techane (120 points)
edited Aug 22 by William Rasmussen

2 Answers

0 votes

Access the Android Studio's installation folder and remove the contents of the platform-tools. Then download the archive below and copy all the contents to the platform-tools folder.

This is an issue with the 32 and 64bit architecture mode. It should work after you replace the files. As for the virtual machine, make sure that when you create one to download the requirements and no error appears during the installation.

answered Aug 22 by Robert Polubinski (221,940 points)
0 votes

Dear Robert Polubinski,
Thank you very much for your answer.
It is working now. I have changed my Kali Linux 32 bit to amd64 bit architecture and I have installed Android Studio 3.3 version. It is working well. The reason that why it does not work on 32-bit architecture, Android Studio does not support for 32-bit Linux architecture. So, the solution is that installing 64-bit architecture Linux distro and install it.
Thank you very much.

answered Aug 22 by Dejene Techane

Your answer

Your name to display (optional):
Email me at this address if my answer is selected or commented on:
Privacy: Your email address will only be used for sending these notifications.
Anti-spam verification:
To avoid this verification in future, please log in or register
...